Upgraded to 2019, but database shows version number doesn't match

All issues and questions relating to Turbo Tourney Pro should be posted here. Support members, forum moderators and other members can help you with your questions.
Post Reply
ggorman
Posts: 5
Joined: Fri Mar 15, 2019 8:45 am

Upgraded to 2019, but database shows version number doesn't match

#1

Post by ggorman » Fri Mar 15, 2019 8:50 am

We updated to 2019 and initially tried to re-use our database from last year, but that didn't work (version number doesn't match). So, I created a new database with the script provided in the 2019 version but I still get the version number error when trying to save my new TT file (The version of Turbo Tourney Pro you are using does not match the version number that was used to create the database). How can this be resolved?

User avatar
Doug
Posts: 372
Joined: Tue Jul 22, 2014 3:06 pm
Old Username: Doug
Location: Ankeny, IA

Re: Upgraded to 2019, but database shows version number doesn't match

#2

Post by Doug » Fri Mar 15, 2019 12:51 pm

What type of database server are you using?

ggorman
Posts: 5
Joined: Fri Mar 15, 2019 8:45 am

Re: Upgraded to 2019, but database shows version number doesn't match

#3

Post by ggorman » Fri Mar 15, 2019 12:53 pm

SQLServer 2008

User avatar
Doug
Posts: 372
Joined: Tue Jul 22, 2014 3:06 pm
Old Username: Doug
Location: Ankeny, IA

Re: Upgraded to 2019, but database shows version number doesn't match

#4

Post by Doug » Fri Mar 15, 2019 1:25 pm

And when you created the database you ran the init_sqlsserver2008_database.sql script to initialize the database? That should have set the version to 2019:

INSERT INTO [dbo].[sysVersion] Values (2019)

Can you query that table and see what value is in there?

ggorman
Posts: 5
Joined: Fri Mar 15, 2019 8:45 am

Re: Upgraded to 2019, but database shows version number doesn't match

#5

Post by ggorman » Fri Mar 15, 2019 1:56 pm

Yes, and I verified the version number. I had attempted to re-use the database from last year, updating the sysVersion directly, but when that didn't work I stood up a new database with the 2019 files.

User avatar
Doug
Posts: 372
Joined: Tue Jul 22, 2014 3:06 pm
Old Username: Doug
Location: Ankeny, IA

Re: Upgraded to 2019, but database shows version number doesn't match

#6

Post by Doug » Fri Mar 15, 2019 2:23 pm

If the version is 2019 then it should match. Are you certain you've updated the connection to point to the new database with the 2019 version number?

ggorman
Posts: 5
Joined: Fri Mar 15, 2019 8:45 am

Re: Upgraded to 2019, but database shows version number doesn't match

#7

Post by ggorman » Fri Mar 15, 2019 2:30 pm

verified that the connection is to the new database and that the sysVersion says 2019. The file was upgraded from last year (if that makes any difference) and I get successful message when testing the connection

User avatar
Doug
Posts: 372
Joined: Tue Jul 22, 2014 3:06 pm
Old Username: Doug
Location: Ankeny, IA

Re: Upgraded to 2019, but database shows version number doesn't match

#8

Post by Doug » Fri Mar 15, 2019 2:34 pm

I supposes it's possible that the upgraded file might be causing the problem but then I would have thought it would work with the 2018 database from last year but if you're saying it's not working against either a 2018 or 2019 sysVersion value that doesn't seem right. Can you send your pool file to me at support@turbotourney.com and I'll have a look?

ggorman
Posts: 5
Joined: Fri Mar 15, 2019 8:45 am

Re: Upgraded to 2019, but database shows version number doesn't match

#9

Post by ggorman » Fri Mar 15, 2019 2:53 pm

Sent file via email. Let me know if you didn't receive the email or if the attachment was stripped out or anything.

Post Reply